Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error on installation, can't register
I have already installed and am using RunAsXP on my Dell laptop. When I tried to install on my Toshiba laptop I received the error message shown below. The launcher tries to start the program but when I enter the installation key I get the error message "cannot connect to server". My internet connection is functioning correctly as I would otherwise not be able to connect to this forum.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Customized cultures cannot be passed by LCID, only by name.
at System.Globalization.CompareInfo.GetCompareInfoWithPrefixedLcid(Int32 cultureKey, Int32 prefix)
at System.Globalization.CultureInfo.get_CompareInfo()
at System.String.Compare(String strA, String strB, Boolean ignoreCase, CultureInfo culture)
at System.Windows.Forms.ComboBox.set_Text(String value)
at System.Windows.Forms.ComboBox.UpdateText()
at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
at oe_setup_f.OeSetup.OeSetup_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/Outlook%20Express/oe_setup.exe
Assembly Version:
Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/
Assembly Version:
Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/
Assembly Version:
Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

< jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Please try closing any antivirus or firewall that may block connection and retry installing.

(01-18-2016, 05:22 PM)Rafail Wrote: Please try closing any antivirus or firewall that may block connection and retry installing.

I have tried again after closing AVG and adding Outlook Express to the firewall exceptions but I still have the same error messages. A quick scan of the Microsoft forums indicates that the error message is generally caused by some sort of conflict in regional settings so I have stripped out all references to regions and reset to English (USA). However this has also not helped. I have also just completed a successful installation on my Dell desktop. All three systems run under windows 10 but the two systems where the installation has worked run in UK English with Spanish keyboards. The Toshiba where I am having the problems runs normally in UK English with a UK keyboard. What next?
Connect it though Ethernet cable if currently is connected with WiFi.
Normally this should not happen, Regional setting does not affect that but maby some bad setting on your network connections.

Try the suggestion above (connect through LAN if now you are connected with WiFi) and temporary disable all network connections except ethernet.

Since you have successfully installed it on your other computers then the problem is not on your internet connection but on that laptop.
Also verify that you have latest version 2.1

Using a cable connection does not make any difference I am still getting exactly the same error messages. The error message clearly states that there is a System.ArguementException. This has nothing to do with Internet connections. The connection works both direct and through Wifi. Is there a log file of the installation which might give some further clues as to where the problem lies?
The error you said was "cannot connect to server", that's why i firstly suggested checking connections.

Since you had checked all connection ways you still got error "cannot connect to server"?
That error comes same time with the "Customized cultures cannot be passed by LCID, only by nam" error?

For the "Customized cultures cannot be passed by LCID, only by nam" after a research i found that this is actually a windows error (bug) affecting some installers and programs (like OE installer).

It's actually very rare to happen and, yes, it has to do with regional settings.

I will suggest you these steps as Microsoft suggests for this error, unfortunately it has not to do specially with oe (and setup development) so these are only suggestions i can provide. If no success then you should really think about a clean install of your OS.
1. Navigate to "C:\Windows\Globalization", if you have there any files with .nlp extention, rename them temporarly to .nlp.old
2. Open Control Panel > Region > Formats Set it to English (United States). Try with other languages if no success, remember to reboot after changing that setting.
3. Try with a new user, create a new user and try installing oe.


Forum Jump: