Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] OE6 2.0.0 install fails, OE runs anyway, but badly
•Under Windows 7 64bit, 8GiB, with Kaspersky Endpoint Security 10, the OE6 2.0.0 installer (oe6_2.00.exe) failed with an error:
"Registration of one or more DLLs failed due to system security. Please restart your computer, disable any Antivirus software during installation, close any open programs and run setup again. In case that fails, try installing Outlook Express in Safe mode with networking. Error details: DLL:0.g64..764..s64." (Image attached.)
•After restart in Safe Mode with Networking, the installer failed with THE SAME error.
•Back in normal mode, I launch with the official shortcut (C:\Windows\System32\schtasks.exe /run /tn "StartOE"), and nothing happens at first. But StartOE.exe is running, and StartOE launched msimn.exe right away, but no OE window appears. StartOE's number of handles counts up by about 2 per second. At 2 minutes 5 seconds (unacceptable wait time), or when StartOE reaches about 200 handles, the Outlook Express window appears and seems to be running normally. OE can even check mail and complete a "File:...Compact all folders" operation. However, StartOE.exe keeps on adding two handles per second. It counted as high as 1180 before I stopped it. (That can't be right; it has to crash eventually.) •Another surprise: StartOE.exe and msimn.exe are running at Base Priority of "Below Normal". •I uninstalled 1.7.6 first. After installing 2.0.0, my email Accounts survived, but all of my saved email passwords were lost.
•For now, I have to go back to 1.7.6.

Have you tried installing with Kasprsky turned off?
Antivirus programs some times blocks the installer. please try disabling Kaspersy.
Also make sure that you are installing on c: drive and not on other drive or partition and final run the installer as 'Administrator'.

•I got it now. I think you were close when you said "run the installer as 'Administrator'". On my previous attempts, I have been logged in as a user whose profile is stored under "D:\Users". (I like to keep my data drive separate from my OS & applications drive. It makes backup and recovery simpler.) That seems to be the culprit. So I logged in as a different user, one whose profile is stored under the default "C:\Users". Also I shut down Kaspersky (as before). This time oe6_2.00.exe install succeeded, so OE6 2.0.0 is working for me now. There is a bug in your installer; needs a ticket or a warning to users.
•After a successful install of 1.7.6 or 2.0.0, I got my saved email passwords back. (Mysterious, but it is a good thing.)
•After a successful install, you created one false key in the Registry, pointing to "C:\Program Files\Outlook Express\msimn.exe" instead of "C:\Program Files (x86)\Outlook Express\msimn.exe". You can find the bad key by running CCleaner before and after installation.
•StartOE.exe and msimn.exe still run at Base Priority of "Below Normal". This probably is not right, but it does not cause any problems (yet). Also I can't raise their priority to Normal, permission is denied.
•StartOE.exe still adds about 2 handles every second (1800 at this moment). This cannot be right. I will leave it running this way to see what eventually happens, and report that separately. One obvious workaround is to simply skip StartOE.exe and run "C:\Program Files (x86)\Outlook Express\msimn.exe" directly. (This is the same shortcut you create to "Run OE without administrator privilege", which only prevents one kind of drag-and-drop operation, so it should not be a problem.)
- The problem when installing to different hard drive or to users that have different user path is known and will be fixed. That's why i always reccommend installing on C drive.
- The email passwords actually never 'dissapeared', but if installation is not completed successfully oe will always ask for password.
- The priority of executables (startoe and msimn) is as it should be.
-Startoe.exe is the main executable, it has some handles (instancies) beacuse it interracts with msimn.exe, it is normal and dont worry about that. In any case you can run msimn.exe directly but you wont have the right click context menu with these usefull settings. In case that you run msimn directly you must add administrative previliges to shortcut.

Thanks for sharing your solution.


Forum Jump: