Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Office365 SMTP does not work
#1
I have confirured Office365-hosted IMAP account as specified at https://support.office.com/en-us/article...7113525f6c

IMAP works OK, but SMTP does not. An attempt to send an email results in the immediate

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'Test', Server: 'smtp.office365.com', Protocol: SMTP, Port: 587, Secure(SSL): Yes, Error Number: 0x800CCC0F

I attached the trace collected in Network Monitor - rename .txt to .cap.
Reply
#2
Hello,
port 587 does not work on oe with newer windows. It has beed discussed many times.
Suggested alternative port is 25 that normally will work.
Rafael
Administrator
-------------------------------------------------

Reply
#3
I was delighted to find this software. The laptop I am using it on travels with me and my Email Service Provider has a secure smtp service I can access from anywhere. I have been doing so with Thunderbird. I read many of the issues that people had and that were solved and gained confidence enough to donate and download the RunAsXp Outlook Express.  Unfortunately one thing I did not focus on or notice was the outgoing port. My Email service Provider uses only port 587 with SSL. Although I feel the software is fully worth the donation and I still have a taste of the feeling of relief in finding it and trying it out, but I can't get around this obstacle. I have to regretfully ask if I can back out of the donation/download agreement.
Reply
#4
Hello,
please give a try first with port 587 without SSL checked. This usually works.
Rafael
Administrator
-------------------------------------------------

Reply
#5
Thank you for your response.

I tried again both with and without SSL checked (changing nothing else in Advanced or Servers Tabs).

Here are the error messages for each condition (in both cases the email was `sent' to myself; you will have this but I obscured it so it could not be harvested):

__________________________
Error message without SSL:

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'xxxxxxx@vcn.bc.ca'. Subject 'testing no SSL', Account: 'VCN via out.vcn', Server: 'out.vcn.bc.ca', Protocol: SMTP, Server Response: '554 5.7.1 <xxxxxxx@vcn.bc.ca>: Relay access denied', Port: 587, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79


Error message with SSL:

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'VCN via out.vcn', Server: 'out.vcn.bc.ca', Protocol: SMTP, Port: 587, Secure(SSL): Yes, Error Number: 0x800CCC0F
__________________________

The `vcn' domain (Vancouver CommunityNet) made this smtp server available for those who did not have an ISP but encouraged those who had their own ISP to use those smtp servers and settings. The port 587, I have read, has extra security against spam coming from within the domain and I believe this is why they chose it. I asked them if I could use or if they could open traffic to port 465 but they said "587 is the default."   So they aren't going to change.

I have found that the "Server Response" for no SSL, 554 5.7.1, is usually related to a Spam filter blocking traffic. This is consistent with the above motive for using of port 587 and that the VCN is often attacked by spammers. They have in the fairly long past been temporarily blacklisted because someone or several  people using their domain were infiltrated by a spammer/malware program.

Maybe someone will come up with a driver that accommodates using port 587 with OE in Windows 10!

Regards,
Steve Summers
Reply


Forum Jump: